Zwei kleine Probleme

Hallo

Erstmal vielen Dank für das tolle Album. Nach einigem rumprobieren habe ich alles soweit zum laufen gebracht. Ich habe aber noch 2 kleinere Probleme, die mich verrückt machen, weil ich die Lösung nicht finde. Galerie zu finden unter www.fages.de/galerie

1) Galerie-Icon

Ich habe keine Thumbs für die Galerie eingestellt, sondern nutze die Icons. Komischerweise zeigt er mir seit heute "leere" Ordner für manche volle Galerien an, bei anderen wiederum das korrekte Icon "mit Inhalt" -> so zB unter "Studireiten".
Das hat zu Beginn alles geklappt, nun auf einmal nicht mehr.

Edit: Stelle gerade fest, dass es offenbar bei den Alben so ist, die nur Unterordner, aber keine Bilder haben. Zunächst war das nicht so, und zwischendurch war es bunt gemischt.

2) Der "View"-Zähler

scheint irgendwie nicht zu funktionieren. Gestern hatte ein Bild noch 3 views, heute 0. Wo wird das eigentlich hingespeichert und könnte ich den auch deaktivieren?

Danke für Deine Hilfe,
Gruss ff

Hallo froufrou, also gleich

Hallo froufrou,

also gleich zu deinen Fragen:

1) die Icons "mit Inhalt" bedeuten eigentlich dass das Verzeichnis "Neu" ist, oder dass es in dem Verzeichnis veränderungen gab. Die dauer wie die Verzeichnise als neu angezeigt werden kann man in Stunden einstallen, und zwar in Setup-Main Setup->"New files in gallery indicator:". Ich arbeite allerdings schon daran, dass es möglich wird die Anzal der bilder in den Galleries angezeigt werden kann.

2) Ja, du kannst es einstellen in Setup-Thumbnails. Für jede Größe kann man einstellen was angezeigt werden soll. Allerdings müsste es auch funktionieren. Bei der Anzeige der neusten Bilder wird die Information allerdings gecacht und nur einmail in 24 Std. erneuert. Diese dauer ist leider noch nicht einstellbar, kommit in der nächsten Version.

Viele Grüße aus Augsburg!

Patrik

Vielen Dank für die

Vielen Dank für die schnelle Antwort!

War wohl schon zu spät gestern, dass ich die Option mit dem View Count übersehen habe.

Das mit den Icons hatte ich nicht kapiert, bin wohl schon funktionsgeschädigt von Windows. Da ist das ja so mit "voll" und "leer".

Noch 2 kleine Anschlussfragen:

Sehe ich das richtig, dass die Verzeichnisse mit den Photos selbst auf 755 bleiben müssen, da sie sonst beim Galeriescan aussen vor bleiben?

Die beiden 777 -Verzeichnisse für den Cache und die Daten - wird da irgendwie abgefangen, dass da einer drin rumhackt? Theoretisch kann doch die jeder aufrufen und drin rumwurschteln, oder nicht?

Tx und Gruss aus Zürich,
froufrou

Also das Verzeichnis für

Also das Verzeichnis für Fotos muss für PHP lesbar sein. In die Verzeichnise für Cache und Daten muss PHP auch schreiben können, deswegen 777. Du hast schon aber recht dass es nicht ganz sicher ist wenn jemand shell Zugang auf den Server hat. Deswegen ist auch gut etwas ungewönlichen Namen für die Verzeichnise zu haben, normalerweise kommt man nämlich schon ins phpAlbum Verzeichnis nicht rein.

Ich will da aber noch was besseres machen, muss ich erstmal aber testen ob es geht. Man könnte theoretisch die Verzeichnise zu erst mit chown als PHP eigene Verzeichnise einstellen und danach auf 755 ... muss ich testen ob es klappt.

Viele Grüße
Patrik

Hmm, ansich bin ich der

Hmm, ansich bin ich der Einzige mit (shell)Zugriff auf den Server. Fühle mich halt immer mulmig, wenn da ein 777 Verzeichnis rumliegt. Hab jetzt mal eine htaccess mit required user reingepackt. Scheint, als liefe die Galerie noch korrekt. Mal schauen, ob es irgendwann hakt.

Danke für Deine Hilfe und Gruss

froufrou

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.


style="display:inline-block;width:468px;height:60px"
data-ad-client="ca-pub-8698264690166658"
data-ad-slot="4417389723">