Another parsing error

Hi,

I manually loaded up phpAlbum, renamed the folder, created and chmodded the data and cache folders and when I try to access www.mywebsite.de/privat/phpAlbum I get the following message:

Parse error: syntax error, unexpected '/' in /mnt/web8/43/47/51180647/htdocs/privat/phpAlbum/main.php on line 2049

Since line 2049 doesn't refer to the phpAlbum directory this cannot be caused by my renaming it AFAIK. Or does it?

I also tried the webinstaller, but this gives me an error message too. After accessing FTP and letting me chose the desired directory, it say "Unable to create directory". It creates "phpAlbum" with "lang" and "res", though...

Any ideas? I am clueless...

Thanx a lot!

Can you give the right url

Can you give the right url to your site, because when I use the given url (www.mywebsite.de/privat/phpAlbum) I get an advertisment-site.

---
Joep Meijer

Using phpAlbum on
fotos.vanjoep.nl

Sorry, here it is

http://www.texthexe.de/privat/phpAlbum/main.php?cmd=album

Thanx in advance!
;-)

You probably made an error

You probably made an error during manual setup.

I think it's much easier to do a web-install. After installation you can change the folder to your own will.

---
Joep Meijer

Using phpAlbum on
fotos.vanjoep.nl

Well... I tried the web installer too...

As written in my first comment, I deleted everything from the server and then tried the web installer. It connected OK, looked for a former installation, found none and then said "Unable to create directory". The folders "phpAlbum", "lang" and "res" were created anyway, nothing else. No matter if I tried the root directory or a subfolder (of course deleting the cache between each attempt).

So, NOW any suggestions?

Sorry, missed the part of

Sorry, missed the part of the web-installer.

The directory you want to put phpAlbum in, you created this one manually?
What are the rights on that folder?

I've done a web-install myself on a sub-domain I made and gave the directory during installation. And I have no problems with it.

---
Joep Meijer

Using phpAlbum on
fotos.vanjoep.nl

Good morning, Joep

I tried both an existing folder and the default where web installer creates one. When I used the existing folder I didn't change any rights, because the installation guide doesn't have it and in the description it says you don't have to know anythink about chmodding.

In the issues someone describes the same problem, so I will add mine there too...

Thanks anyway.
Bye

1 step further...

OK, now I took the main.php of the manually installed version and greyed out (with /*...*/) lines 2049 to 2054 and - ta-dah! I can access my phpAlbum online. I even can log in with admin/admin, but get the message "You are not allowed view this page or download this image!"

When I try to click "Setup" in the upper right it is linked to "phpAlbum/themes/Borders/main.php", which cannot be found since it doesn't exist. I looked it up in the downloaded .zip file and it doesn't exist there, too.

Now, what is going on here?

(Oh, I am getting the "You are not allowed..." even if I chmod the whole phpAlbum folder and all its subfolders to 777 - what more right could I possibly give?)

Hey, you obviously have a

Hey,

you obviously have a problem setting up the album. I looked at your site and it is very very strange :)

If you like, send me your ftp account info and I could install it for you.

Patrik

Thank you!!!

Hi Patrik,

thanx a lot for solving this mysterious problems! Now I'm going to enjoy the new phpAlbum and recommending it to everyone...!

Have a nice weekend!

Thank you!!!

Hi Patrik,

thanx a lot for solving these mysterious problems! Now I'm going to enjoy the new phpAlbum and recommending it to everyone...!

Have a nice weekend!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.


style="display:inline-block;width:468px;height:60px"
data-ad-client="ca-pub-8698264690166658"
data-ad-slot="4417389723">