Running into problems scanning newly added directories

I'm slowly adding more directories of .jpgs... at a point it seems to timeout waiting for the web server (which appears to have finished)... and when navigating to the main ./gallery page... I get the following...

upgrading from:to 0.4.1.14
applying changes for 0.4.1.9 version
applying changes for 0.4.1.10 version
applying changes for 0.4.1.11 version
applying changes for 0.4.1.12 version
applying changes for 0.4.1.13 version
applying changes for 0.4.1.14 version

Fatal error: main(): Failed opening required 'lang/' (include_path='.:/usr/share/pear') in /var/www/html/hustonfamily/gallery/language.php on line 7

I see this was reported by other users in the past.

The 'scan' was taking a considerable amount of time... as I'm adding alot of files (although attempting to do it incrementally so as to not overwhelm it... if possible). What happens if more than one client comes in ... and initiates a directory scan? Is that possible? possibly creating a conflict?

I'm having a very difficult time adding in new files. It works great up until about 7,500 photos. Beyond that... the directory scan takes long enough... problems seem to occur.

Hi, I not sure if I had got

Hi,

I am not sure if I had got the same error message like you have, but I had problems with the directory scan when the amount of pictures was above a specific limit and solved it by increasing the available amount of memory in the main.php:

[code]
ini_set('memory_limit', '82M');
[/code]

I at first asked my host to increase this value, but he refused to provide this. Then I just changed this line in main.php and it works now for me since over a year.

Mybe give it a try.

Regards
Klaus

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.


style="display:inline-block;width:468px;height:60px"
data-ad-client="ca-pub-8698264690166658"
data-ad-slot="4417389723">